jquery-migrate-3.0.1.js CDN地址、下载地址

时尚彩妆 2019-11-18 297 阅读

支持 console.trace( ) 来跟踪警告信息,更易于诊断错误

对于无效 json,会返回警告信息

提示“Logging is active”信息,以表明插件正在运行

jQuery 1.9 限制了字符串的处理,你可以通过新版 Migrate 插件来恢复该功能。但还是建议使用 $.parseHTML( ) 来处理 HTML

对 $("<button>", { type: "button" }) 会显示一个错误警告

《 1.9 版本对于 pve(),die(),toggle(),sub(),$.browser 等等都已经不支持了 》

《 在不改变你网站代码的同时,你需要使用 jquery-migrate 1.9 之后的版本 》

jquery-migrate-3.0.1 - 使用

jQuery-Migrate 是一个过渡插件让你在原来代码上升级 jQuery 不用修改代码

<script src="https://code.jquery.com/jquery-migrate-3.0.1.min.js"></script>

注意:js 和 css 的对应标签应该位于页面的 <head> 部分。在 HTML5 中可以不使用 type 属性 , 所有现代浏览器都支持!

最新游戏